Get in touch
Back
Maintenance

BinWeigh 03 Portal Vehicle Status Processing Updates - IT MAINTENANCE

Completed 7 Apr at 11:00pm IST.

https://portal.binweigh3.com
Completed

Maintenance completed

Posted 7 Apr at 11:00pm IST.
Started

We are carrying out essential IT maintenance and updates to our BinWeigh 03 Vehicle Portal. You may experience short downtime during this period. We apologize for any inconvenience caused.

Posted 6 Apr at 10:30am IST.